PLEASE SHARE

Older Kindles need critical update today!

Kindles normally update themselves when connected to the Internet. However, users who have an older model lying around, switched off or disconnected from the net, should make sure this critical update has been installed.

Devices affected are Kindle Paperwhite 5th generation from 2012, Kindle DX 2nd generation from 2009, and Kindle Keyboard 3rd generation from 2010. Regular Kindles, generations 1, 2, 3 and 4, from 2007, 2009, 2011 and 2012, also need to be updated.

Newer models don’t require this update.

Read more via Stan Schroeder’s blog post on this topic … Older Kindles need to be updated by March 22 to stay online

Comments Off on Older Kindles need critical update today!
Posted on by Sue
Categories: Techie Tuesdays